Flash Not Powering Up

My wife bought a Yongnuo 564 Iv flash as a gift for me last Christmas. I used it once and removed the batteries. I tried to use it last night, put in fresh batteries and the flash will not power up.
Does anyone have any ideas?

That should be not powering up. Sorry.

Fixed the title for you, Brian.

Thank you, today is one of those days.

These flashes have a history of not starting up after not being used for a while. First, check to see if you can get a warranty replacement. Also check for corrosion on the battery contacts. Sometimes the contacts get pushed down and they fail to make a strong contact with the battery. Try a different set of batteries, sometimes you can get a dead battery in a package. Do a search for this flash as there are other issues that people have discovered and you may find a solution for your problem…Jim

Thanks Jim, I tried everything you mentioned, different batteries, contact inspection, even reaching down with a paper clip to lift the contacts to ensure connection. Everything looks brand new. My wife bought it through Amazon and it is almost a year old so I doubt any warranty will be available. Just proof that you get what you pay for. I will keep plugging along.