Problem seeing images

The last few days, very often the images take a very long time to show on the screen. I haven’t had problems with other sites. Is something going on with my settings? Don’t think I have changed anything.

Diane, I have had a similar issue in the last few weeks. since Thanksgiving, I have also had issues with downloading members images to use for a rework, it takes a very long time.

Hi Diane, I’m sorry I missed this until now since it was in the general discussion area. Are you still having this problem?

Ed, is this just happening when downloading images specifically?

If anyone else is having this problem please let me know, any details you can provide will help. I’m not seeing any problems on my end or anything that would cause problems for anyone, but I will dig into it if I can get some more details.

Yes, I still have the issue. It’s random, as far as I can tell, and happens on FF, Safari and Chrome. It’s not just when I download an image, but often when I try to view a post and the image isn’t there, just its name. Recently it happened for the first time when I tried to upload an image.

If it matters, I’m on a Mac Pro, Mojave, with fast and stable fiber optic (ATT Uverse) broadband. Have never seen this happen anywhere else.

Do you have any ad blockers or firewall installed Diane?

If you have the time I could use your help to troubleshoot this. When the problem occurs please right click on the page (not on an image) and click Inspect Element, then go to the Console tab of the new window that pops up. If there are any errors in red please take a screenshot of that and post it here. I’m very sorry for the trouble, this is a tough one to troubleshoot since it seems to be limited to you, I think Ed’s problem is different.

Yes downloading all images seems to be the problem now (experienced today). never a a problem until recently. Maybe it’s my internet provider, but I have Comcast broadband connected to a PC via ethernet cable.

A couple things you can try Ed, first let’s see what your internet speed is by going to

Have you tried using a different browser like Chrome or Firefox? You might just need to clear your cache.

Thanks for the help David. My download speed is 45 mbps. I have been using Firefox, will try clearing cache, and/or using Chrome, an dwill report back.

Clearing cache did the trick, thanks David.

1 Like

It happened first try on an image this morning, loading the large size, but it came up after a few minutes. Nothing obvious showed as an error in the console. Then on the next one I couldn’t see the image in the initial post. Screenshot here. The console only showed one suspicious item, a triangle/exclamation point in the last item in the middle tab.

I don’t know if FF has any sort of blocker, but I doubt Safari and Chrome do. I’ll see if I can find anything. Meanwhile I have turned off the Apple OS firewall and will see if that fixes it. The odd thing is, I hadn’t updated anything I’m aware of before this started. It started quite suddenly maybe mid-November and seems to have gotten worse. That’s very un-computer-like behavior!

Ah, I see I was in the Inspector tab, instead of the Console tab. Have left it on and will keep watching it. Meanwhile, I turned off the OS Firewall and that seems to have fixed the problem. But don’t I want to have it on for most browsing? Could just turn it off for NPN, though.

@David_Kingham, my last 3 posts above are probably irrelevant. Firewall now back on and I got several posts OK then got this:

Another clue? This time the more recently posted rework didn’t show up, and I grabbed the Console screenshot. Then the repost came up, but nothing changed in the Console, even after I closed it and went back in.

Hmm I’m still not seeing anything that would explain this. Could you try going into safe mode for me? and leave all the boxes checked. It will look very stripped down, but try opening some topics and see if the problem still happens.

No boxes to check. I get this screen, and testing it would close the window…

There is not an option to upload (due to safe mode?) and the screenshot took a long time but finally did upload by drag and drop.

I don’t know anything about Firefox ad blockers or the like. Any info?? Things seem to work better on Chrome.

If it’s working better in Chrome then you might need to clear the cache in your browsers as well, especially Firefox. Here’s a guide for you.

I’ve cleared the cache and still get the issue, but seemingly less. I’ve now disabled hardware acceleration and that may have been the issue. So far, so good.

Thanks for the help!

1 Like