Some images not loading during first page load

Hi NPN Team,

I’m experiencing some weird and seemingly random behavior with images (eg. posts in Critique section) not loading during first page load. However, after refreshing the page they usually come up properly. I tested two different browsers (Chrome & Safari, newest MacOS) and the issue persists on both of them. I have any adblockers disabled and JS is turned on. It seems like a potential CDN or caching issue to me, but I might be wrong. Also, I’m not sure if anyone else experienced this so far.


Hi Andrzej,

I haven’t seen this recently, so it could very well be related to the CDN in your area. I’ve looked over the logs for the CDN and don’t see any requests from Poland, so it’s hard to say if that’s really the issue. Since you sound tech savvy, could you do me a favor and right-click on one of the images when this happens and click Inspect, in the new window that pops up, click the Console tab. Take a screenshot of this window and send it over, this may help us troubleshoot if there is anything relevant. Also, note the exact time it happened so I can look at the logs closer. Thanks!

Hi David,

I’m not using any VPN and my public IP address should be definitely a polish one.

With one of the images on category pages I got a lot of console warnings regarding missing css stylesheets, but also few 502s.

Errors in Console

Warnings in console

Also, you can see the difference if browser can access this particular image on this particualr request. For instance, the image next to it is fine:

But this one doesn’t have neither preview nor dimensions:

Upon clicking the link of the image I got redirected to the new tab where the image loads up properly. I tried refreshing the category page, but with no luck this time. This particular image is still missing and I still got some 502s which are, in fact, for this file among others.

Missing file name: f64c300badf9f5ad008a7c5ed1b82a6f41c3df8d_2_1024x576.jpeg

I did the test right now - the timeframe was 8:30 - 8:43 pm CEST, on Chrome.


However, when I switched to Incognito mode, the image was there without any issues (both Chrome & Safari) and no 502s in the Console.

So, I guess it is a caching issue, only on my part. :sweat_smile: Sorry for all the fuss, I should’ve checked it sooner. I’ll just clear all the site data and it all should be resolved.

EDIT: Unfortunatelly, it’s not. I’ve cleared all the site data and now it’s even worse. Not really sure what it could be. I didn’t install any new plugin recently and this is fairly new issue for me. But since the Incognito mode worked well there may be some clue there…

EDIT 2: I’ve went with the route of disabling all my Chrome plugins and all images came back. I turned them all back on, and the images are still there. I don’t know what was the issue here, really, but it was probably on my end. Sorry once again for the fuss.

No worries, glad you figured it out!

1 Like